// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)[^\p{L}\p{N}-]+").unwrap();
let string = "abcd
ab-cd
müller
1248
ab99
straße
café
façade
São-Paulo
România
etc..
!
\"
§
$
%
&
/
(
)
=
?
`
>
°
^
_
<
|
#
'
@
,
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}