$re = '/[^\p{L}\p{N}-]+/mu';
$str = 'abcd
ab-cd
müller
1248
ab99
straße
café
façade
São-Paulo
România
etc..
!
"
§
$
%
&
/
(
)
=
?
`
>
°
^
_
<
|
#
\'
@
,
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);