re = /[^\p{L}\p{N}-]+/m
str = 'abcd
ab-cd
müller
1248
ab99
straße
café
façade
São-Paulo
România
etc..
!
"
§
$
%
&
/
(
)
=
?
`
>
°
^
_
<
|
#
\'
@
,
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end