#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ *([0-9]+) *$"
Local $sString = "1234" & @CRLF & _
" 111 " & @CRLF & _
" 111 " & @CRLF & _
"1a234" & @CRLF & _
"aa1234aa" & @CRLF & _
"1234a" & @CRLF & _
"12#4" & @CRLF & _
" 11 111" & @CRLF & _
" 11 111#" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"111" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")