re = /^ *([0-9]+) *$/m
str = '1234
111
111
1a234
aa1234aa
1234a
12#4
11 111
11 111#
111
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end