package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^ *([0-9]+) *$`)
var str = `1234
111
111
1a234
aa1234aa
1234a
12#4
11 111
11 111#
111
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}