import re
regex = re.compile(r"^ *([0-9]+) *$", flags=re.MULTILINE)
test_str = ("1234\n"
" 111 \n"
" 111 \n"
"1a234\n"
"aa1234aa\n"
"1234a\n"
"12#4\n"
" 11 111\n"
" 11 111#\n\n\n"
"111\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")