using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\\.+, .+?\\([0-9]+) - .[^\\]+(.*)";
string input = @"
\\Folder 1\Folder 2\surname, forename\1234 - some really long name\some folder\5678 - some other name";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}