$re = '/^\\\\.+, .+?\\\\([0-9]+) - .[^\\\\]+(.*)/m';
$str = '
\\\\Folder 1\\Folder 2\\surname, forename\\1234 - some really long name\\some folder\\5678 - some other name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);