re = /^\\.+, .+?\\([0-9]+) - .[^\\]+(.*)/m
str = '
\\\\Folder 1\\Folder 2\\surname, forename\\1234 - some really long name\\some folder\\5678 - some other name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end