import re
regex = re.compile(r"^\\.+, .+?\\([0-9]+) - .[^\\]+(.*)", flags=re.MULTILINE)
test_str = ("\n"
"\\\\Folder 1\\Folder 2\\surname, forename\\1234 - some really long name\\some folder\\5678 - some other name")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")