package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([\da-f]+)\]`)
var str = `[a1204f778edb7b4b]
[askjhd_zxcvjer4v]
[69e2176e8a5dcf8b]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}