$re = '/\[([\da-f]+)\]/';
$str = '[a1204f778edb7b4b]
[askjhd_zxcvjer4v]
[69e2176e8a5dcf8b]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);