const regex = /\[([\da-f]+)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([\\da-f]+)\\]', 'g')
const str = `[a1204f778edb7b4b]
[askjhd_zxcvjer4v]
[69e2176e8a5dcf8b]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}