package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:http|ftp)s?://)?[\w:@.-]+\.[\w-]+(?::\d+)?\??[\w.\~:/?#\[\]@!$&'()*+,;=.%-]*$`)
var str = `http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy yy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}