re = /^(?:(?:http|ftp)s?:\/\/)?[\w:@.-]+\.[\w-]+(?::\d+)?\??[\w.\~:\/?#\[\]@!$&'()*+,;=.%-]*$/m
str = 'http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy yy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end