$re = '~^(?:(?:http|ftp)s?://)?[\w:@.-]+\.[\w-]+(?::\d+)?\??[\w.\~:/?#\[\]@!$&\'()*+,;=.%-]*$~m';
$str = 'http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy
http://goooooooooooooooooglllllllllllllllllllllllllllllllllllllle.com:12?queryyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyyy yy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);