#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\b(bc|sp|mc)-\b(cu)-*$" & @CRLF & _
"^(.*?\b(bc|sp|mc)\b)(.*?\b(bc|sp|mc)\b)(.*?\b[a-z0-9._%+-]\b).*$"
Local $sString = "bc-cu" & @CRLF & _
"bc-mc-test99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")