const regex = new RegExp('^.*\\b(bc|sp|mc)-\\b(cu)-*$
^(.*?\\b(bc|sp|mc)\\b)(.*?\\b(bc|sp|mc)\\b)(.*?\\b[a-z0-9._%+-]\\b).*$', 'gm')
const str = `bc-cu
bc-mc-test99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}