package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\b(bc|sp|mc)-\b(cu)-*$
^(.*?\b(bc|sp|mc)\b)(.*?\b(bc|sp|mc)\b)(.*?\b[a-z0-9._%+-]\b).*$`)
var str = `bc-cu
bc-mc-test99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}