$re = '`^.*\b(bc|sp|mc)-\b(cu)-*$
^(.*?\b(bc|sp|mc)\b)(.*?\b(bc|sp|mc)\b)(.*?\b[a-z0-9._%+-]\b).*$`m';
$str = 'bc-cu
bc-mc-test99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);