#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{1,3}-\d{1,3}|\d{1,3})(?:, ?(?:\d{1,3}-\d{1,3}|\d{1,3}))*$"
Local $sString = "1-100,134,200" & @CRLF & _
"1,18,100" & @CRLF & _
"1, 18, 100" & @CRLF & _
"1, 18,100" & @CRLF & _
"1-,18,100" & @CRLF & _
"-2,18,100" & @CRLF & _
"1,,18,100" & @CRLF & _
"1, ,18,100" & @CRLF & _
",2,18,100" & @CRLF & _
"1,18,100,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")