$re = '/^(?:\d{1,3}-\d{1,3}|\d{1,3})(?:, ?(?:\d{1,3}-\d{1,3}|\d{1,3}))*$/m';
$str = '1-100,134,200
1,18,100
1, 18, 100
1, 18,100
1-,18,100
-2,18,100
1,,18,100
1, ,18,100
,2,18,100
1,18,100,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);