import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{1,3}-\\d{1,3}|\\d{1,3})(?:, ?(?:\\d{1,3}-\\d{1,3}|\\d{1,3}))*$";
final String string = "1-100,134,200\n"
+ "1,18,100\n"
+ "1, 18, 100\n"
+ "1, 18,100\n"
+ "1-,18,100\n"
+ "-2,18,100\n"
+ "1,,18,100\n"
+ "1, ,18,100\n"
+ ",2,18,100\n"
+ "1,18,100,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}