package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\d{1,3}-\d{1,3}|\d{1,3})(?:, ?(?:\d{1,3}-\d{1,3}|\d{1,3}))*$`)
var str = `1-100,134,200
1,18,100
1, 18, 100
1, 18,100
1-,18,100
-2,18,100
1,,18,100
1, ,18,100
,2,18,100
1,18,100,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}