const regex = /A1 (.*), A2 (.*), A3 (.*), A4 (.*), A5 (.*), A6 (.*), X (.*), Y (.*), Z (.*), A (.*), B (.*), C (.*), S (.*), T (.*), BN (.*), TN (.*)(?:(, TOP (.*)])?)\}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('A1 (.*), A2 (.*), A3 (.*), A4 (.*), A5 (.*), A6 (.*), X (.*), Y (.*), Z (.*), A (.*), B (.*), C (.*), S (.*), T (.*), BN (.*), TN (.*)(?:(, TOP (.*)])?)\\}', 'g')
const str = `{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2}
{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2, TOP 32}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}