$re = '/A1 (.*), A2 (.*), A3 (.*), A4 (.*), A5 (.*), A6 (.*), X (.*), Y (.*), Z (.*), A (.*), B (.*), C (.*), S (.*), T (.*), BN (.*), TN (.*)(?:(, TOP (.*)])?)\}/';
$str = '{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2}
{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2, TOP 32}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);