use strict;
my $str = '{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2}
{TRAME: A1 87.75179, A2 -6.815482, A3 8.777070, A4 -0.115212, A5 87.54638, A6 -1.914512, X 97.43790, Y -2582.634, Z 578.5095, A -89.67130, B -4.879062E-01, C 0.130585, S 2, T 42, BN 0, TN 2, TOP 32}';
my $regex = qr/A1 (.*), A2 (.*), A3 (.*), A4 (.*), A5 (.*), A6 (.*), X (.*), Y (.*), Z (.*), A (.*), B (.*), C (.*), S (.*), T (.*), BN (.*), TN (.*)(?:(, TOP (.*)])?)\}/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}