using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S+(?:\s+rate)?\s+\$\d*\.?\d+";
string input = @"Last 4 CommentsFOS rate $10.00 OT/HOL $20.00, AP rate $30.00 OT/HOL $40.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}