const regex = /\S+(?:\s+rate)?\s+\$\d*\.?\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S+(?:\\s+rate)?\\s+\\$\\d*\\.?\\d+', 'gm')
const str = `Last 4 CommentsFOS rate \$10.00 OT/HOL \$20.00, AP rate \$30.00 OT/HOL \$40.00`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}