re = /\S+(?:\s+rate)?\s+\$\d*\.?\d+/m
str = 'Last 4 CommentsFOS rate $10.00 OT/HOL $20.00, AP rate $30.00 OT/HOL $40.00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end