$re = '/\S+(?:\s+rate)?\s+\$\d*\.?\d+/m';
$str = 'Last 4 CommentsFOS rate $10.00 OT/HOL $20.00, AP rate $30.00 OT/HOL $40.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);