$re = '/([[:alpha:]|\s]+\.)/m';
$str = 'This is my string. This string is a sample. This is a problem.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);