re = /([[:alpha:]|\s]+\.)/m
str = 'This is my string. This string is a sample. This is a problem.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end