#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\balarm\.data\.data\.product\.model\b"
Local $sString = "请问这样: 设备模型: ${alarm.data.data.product.modelQualifier} , 设备型号: ${alarm.data.data.product.model} , 设备等级: alarm.data.data.product.model 怎么写 ,我要替换alarm.data.data.product.model, 但是不要替换到alarm.data.data.product.modelQualifier"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")