using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\balarm\.data\.data\.product\.model\b";
string input = @"请问这样: 设备模型: ${alarm.data.data.product.modelQualifier} , 设备型号: ${alarm.data.data.product.model} , 设备等级: alarm.data.data.product.model 怎么写 ,我要替换alarm.data.data.product.model, 但是不要替换到alarm.data.data.product.modelQualifier";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}