import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\balarm\\.data\\.data\\.product\\.model\\b";
final String string = "请问这样: 设备模型: ${alarm.data.data.product.modelQualifier} , 设备型号: ${alarm.data.data.product.model} , 设备等级: alarm.data.data.product.model 怎么写 ,我要替换alarm.data.data.product.model, 但是不要替换到alarm.data.data.product.modelQualifier";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}