const regex = /\balarm\.data\.data\.product\.model\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\balarm\\.data\\.data\\.product\\.model\\b', 'gm')
const str = `请问这样: 设备模型: \${alarm.data.data.product.modelQualifier} , 设备型号: \${alarm.data.data.product.model} , 设备等级: alarm.data.data.product.model 怎么写 ,我要替换alarm.data.data.product.model, 但是不要替换到alarm.data.data.product.modelQualifier`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}