# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(\w+(?:\s*\w*))\s+\1\b/\1/gi;t' <<< "The reason the reason why they cleaned
the the check
"