$re = '/\b(\w+(?:\s*\w*))\s+\1\b/i';
$str = 'The reason the reason why they cleaned
the the check
';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;