use strict;
my $str = 'The reason the reason why they cleaned
the the check
';
my $regex = qr/\b(\w+(?:\s*\w*))\s+\1\b/ip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";