re = /\b(\w+(?:\s*\w*))\s+\1\b/i
str = 'The reason the reason why they cleaned
the the check
'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result