using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z0-9]+[\-|\.]{0,1})+[a-z0-9]@";
string input = @"xxx.sub-domena.vege.love
sub-domena.sub-do-main.dom-ain.com.pl
sub-domena.sub-do-main.dom-ain.co
sub-domena.sub-do-main.dom-ain.vege.love
vege.love
Maxi.Max@
Max-Wielk.Amiu-Max@
maxiu-maxiu-max@";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}