import Foundation
let pattern = #"^([a-z0-9]+[\-|\.]{0,1})+[a-z0-9]@"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
xxx.sub-domena.vege.love
sub-domena.sub-do-main.dom-ain.com.pl
sub-domena.sub-do-main.dom-ain.co
sub-domena.sub-do-main.dom-ain.vege.love
vege.love
Maxi.Max@
Max-Wielk.Amiu-Max@
maxiu-maxiu-max@
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)