import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z0-9]+[\\-|\\.]{0,1})+[a-z0-9]@";
final String string = "xxx.sub-domena.vege.love\n\n"
+ "sub-domena.sub-do-main.dom-ain.com.pl\n\n"
+ "sub-domena.sub-do-main.dom-ain.co\n\n"
+ "sub-domena.sub-do-main.dom-ain.vege.love\n\n"
+ "vege.love\n\n"
+ "Maxi.Max@\n\n"
+ "Max-Wielk.Amiu-Max@\n\n"
+ "maxiu-maxiu-max@";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}