import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=(?:[^\\']*\\'[^\\']*\\')*[^\\']*$)";
final String string = "'E, d MMM YYY', 24, true\n\n"
+ "3, subtract(@{a.b.c}${length()},1)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}