re = /,(?=(?:[^\']*\'[^\']*\')*[^\']*$)/
str = '\'E, d MMM YYY\', 24, true
3, subtract(@{a.b.c}${length()},1)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end