$re = '/,(?=(?:[^\']*\'[^\']*\')*[^\']*$)/';
$str = '\'E, d MMM YYY\', 24, true
3, subtract(@{a.b.c}${length()},1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);