using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\d+)\s*(?:(\w+)?)(?:(\.\w+)?)$";
string input = @"000035 ZSMS_1.mp3
000035 1OMNA
000035";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}