$re = '/^(\d+)\s*(?:(\w+)?)(?:(\.\w+)?)$/m';
$str = '000035 ZSMS_1.mp3
000035 1OMNA
000035';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);